You want to use the FleetMon Explorer and don't know which browser version is suitable? The following browsers are supported:

  • Safari

  • Firefox

  • Edge

  • Chrome

  • Opera

Note: Internet Explorer 11 is not supported by FleetMon and can, therefore, lead to errors in presentation.

Did this answer your question?